Back to overview
Degraded
Some customers might occasionally experience failed identification requests.
Oct 06 at 09:30pm CDT
Affected services
Identification - Global (US)
Identification - Europe
Identification - Asia
Resolved
Oct 07 at 11:09am CDT
We have implemented a fix and will be monitoring to confirm resolution. The issue occurred between 09:00 UTC to 16:00 UTC on Oct 7, 2025 and impacted less than 0.0012% of requests
Affected services
Created
Oct 06 at 09:30pm CDT
Very small % of requests for a small subset of customers might occasionally experience failed identification requests. We are investigating the problem.
Affected services