Back to overview
Degraded

Incomplete Event data returned via Server API

Oct 01 at 04:33pm CDT
Affected services
Server API - Global (US)
Server API - Europe
Server API - Asia

Resolved
Oct 02 at 08:01am CDT

All event data backfill complete. All services operational.

Updated
Oct 01 at 10:28pm CDT

Events backfill complete for Europe region. Backfill in progress for US region, ETA 7 hours. Final update will be posted once it is complete.

Updated
Oct 01 at 09:46pm CDT

Events backfilled for Asia region. Events backfill for Europe region in progress. Next update in an hour.

Updated
Oct 01 at 08:22pm CDT

Data backfill for Asia region in progress. ETA ~1 hour to complete. We will do the other regions after this is complete. Next update in an hour

Updated
Oct 01 at 07:21pm CDT

We are currently testing the data backfill and will be filling the data in manageable chunks, by region. Next update in an hour

Updated
Oct 01 at 05:23pm CDT

We are working on backfilling data. Next update will be in an hour or earlier if we have an update.

Created
Oct 01 at 04:33pm CDT

From September 23rd 22:45 UTC to October 1st 20:31 UTC the "Update Event" method for our Server API in all regions accepted updates but inconsistently applied the updates to one of our backend databases. No update data has been lost, and all records of updates were maintained. However, updates were not applied successfully to one of our databases, this results in the update not being visible on the event when queried via our server API, dashboard, or CSV export functionality for events created in this timeframe.
The underlying bug has been fixed as of October 1st 20:31 UTC, and we are working on backfilling the data. We will re-apply updates from this timeframe to the database that was inconsistent. We will update this status page as we make progress.