Back to overview
Degraded

Service US degradation

Sep 10, 2024 at 02:37pm UTC
Affected services
Identification - Global (US)

Resolved
Sep 10, 2024 at 02:53pm UTC

Degradation resolved.

Created
Sep 10, 2024 at 02:37pm UTC

Degradation caused by an identification subsystem. We're working on a fix.