Back to overview
Resolved
We are experiencing issues with our Dashboard
Aug 6, 2026 at 12:27pm UTC
Affected services
Dashboard
Management API
Resolved
Aug 6, 2026 at 2:25pm UTC
Issue has been resolved and services are back to normal.
Affected services
Updated
Aug 6, 2026 at 1:05pm UTC
We have identified the root cause of the Dashboard disruption and are working to mitigate. Due to the nature of the traffic we're receiving we cannot estimate a return to full availability of the Dashboard at this time.
Affected services
Created
Aug 6, 2026 at 12:27pm UTC
Due to extremely heavy traffic, access to our Dashboard is experiencing issues for some customers. We are investigating and working on mitigation efforts.
Affected services