Back to overview
Resolved

Degraded Search API Performance

Jul 6, 2026 at 8:05pm UTC
Affected services
Dashboard
Server API - Global (US)

Resolved
Jul 7, 2026 at 12:35am UTC

All services have been returned to normal operation.

Updated
Jul 7, 2026 at 12:19am UTC

Our fix has been deployed and we're monitoring our systems to confirm. Performance across all systems should be returning to normal.

Updated
Jul 6, 2026 at 11:59pm UTC

We have identified the root cause and are working on a fix.

Updated
Jul 6, 2026 at 11:48pm UTC

Our team is actively investigating the degraded performance of our Search API. We have opened a support ticket with one of our vendors and are working closely with them toward a resolution.

Updated
Jul 6, 2026 at 10:59pm UTC

Our team is actively investigating the degraded performance of our Search API. We have opened a support ticket with one of our vendors and are working closely with them toward a resolution.

Updated
Jul 6, 2026 at 10:30pm UTC

Our team is actively investigating the degraded performance of our Search API. We have opened a support ticket with one of our vendors and are working closely with them toward a resolution.

Updated
Jul 6, 2026 at 10:06pm UTC

Our team is actively investigating the degraded performance of our Search API and working toward a resolution.

Updated
Jul 6, 2026 at 9:36pm UTC

Our team is actively investigating the degraded performance of our Search API and working toward a resolution.

Updated
Jul 6, 2026 at 9:01pm UTC

Our team is actively investigating the degraded performance of our Search API and working toward a resolution.

Updated
Jul 6, 2026 at 8:05pm UTC

Our team is actively investigating the degraded performance of our Search API. We have opened a support ticket with one of our vendors and are working closely with them toward a resolution.

Created
Jul 6, 2026 at 8:05pm UTC

Search API performance is degraded in our USE-1 region, our Engineering team is aware and working towards mitigation.