Back to overview
Degraded
Dashboard Data Latency
Jun 1, 2026 at 11:08pm UTC
Affected services
Dashboard
Resolved
Jun 2, 2026 at 2:02am UTC
All regions have been restored, and services are operating normally.
Affected services
Updated
Jun 2, 2026 at 1:07am UTC
US region is starting to see recovery. All other regions have fully recovered.
Affected services
Updated
Jun 2, 2026 at 12:28am UTC
We are starting to see recovery in all regions, with the US data delayed by 1 hour.
Affected services
Created
Jun 1, 2026 at 11:08pm UTC
We are currently experiencing a data ingestion delay that is affecting dashboards. There is no data loss as a result of this issue. Our team is working to restore normal operations.
Affected services