Back to overview
Degraded
Ingress endpoint degradation
May 10, 2026 at 10:54pm UTC
Affected services
Identification - Global (US)
Resolved
May 11, 2026 at 12:58am UTC
Services started to come back online. We are monitoring the services to ensure their health
Affected services
Updated
May 11, 2026 at 12:23am UTC
We identified the reason for the incident, and we are working on restoring our services.
Affected services
Created
May 10, 2026 at 10:54pm UTC
We’re currently observing elevated error rates and higher-than-normal latency in our US region for our Ingress endpoint. Our engineers are investigating.
Affected services