Back to overview
Degraded

Server API performance degradation

Apr 27, 2026 at 8:01pm UTC
Affected services
Server API - Global (US)

Resolved
Apr 27, 2026 at 9:02pm UTC

Server API performance has fully recovered. We will continue to monitor the situation.

Created
Apr 27, 2026 at 8:01pm UTC

Server API performance in Global (US) is currently degraded. We're investigating the cause and working on remediation.