Back to overview

Resolved — Dashboard Identification Page

Apr 24, 2026 at 4:23pm UTC
Affected services
Dashboard

Resolved
Apr 24, 2026 at 4:23pm UTC

A small number of trial customers experienced issues loading identification data on the Dashboard Identification page. The incident lasted approximately 20 hours. Identification services were not affected at any point.

The fix was deployed on April 24, 2026. We are monitoring for full recovery.