Back to overview
Degraded
EU region is currently experiencing degraded performance.
Dec 04 at 05:10am CST
Affected services
Identification - Europe
Resolved
Dec 04 at 05:26am CST
The issue with the EU region's degraded performance is resolved.
Affected services
Created
Dec 04 at 05:10am CST
Fingerprint is currently experiencing degraded performance. Our engineering team is working to resolve the issue. We apologize for any inconvenience and thank you for your patience.
Affected services