Back to overview
Demo is down
Jun 13 at 02:39pm CDT
Affected services
fingerprint.com
Resolved
Jun 13 at 02:39pm CDT
The region where our demo works was updated and it is operational again
Affected services
fingerprint.com
Resolved
Jun 13 at 02:39pm CDT
The region where our demo works was updated and it is operational again
Affected services
fingerprint.com