Back to overview
Degraded

Dashboard email delivery is delayed

Mar 28 at 09:44am CDT
Affected services
dashboard.fingerprint.com/login

Resolved
Mar 28 at 11:24am CDT

Email deliverability delays have now been resolved and all emails should be getting processed normally.

Updated
Mar 28 at 10:50am CDT

We have identified a potential reason for the high CPU usage on the dashboard database and are working on a fix.
This email delivery delay is not affecting our production APIs, it's only causing delays on the email deliveries.

Created
Mar 28 at 09:44am CDT

We're observing delays in delivering emails. This affects the dashboard ability to send password reset emails, as well as account confirmation emails.
Our engineering team is working on identifying the problem.