Back to overview
Resolved
Observed Increased Latency for Events
Sep 15, 2026 at 5:00pm UTC
Affected services
Server API - Global (US)
Resolved
Sep 15, 2026 at 9:00pm UTC
Engineers have implemented a fix in the search system, all systems are back to operational.
Affected services
Created
Sep 15, 2026 at 5:00pm UTC
Engineers are investigating reports of increased latency in the Events API in the US region.
Affected services