Back to overview
Resolved
Investigating increased Latency and Errors in the Server API
Aug 25, 2026 at 6:41pm UTC
Affected services
Dashboard
Server API - Global (US)
Resolved
Aug 25, 2026 at 7:11pm UTC
We observed increased load resulting in higher-than-average latencies. We have confirmed full recovery, and all services are operating normally.
Affected services
Created
Aug 25, 2026 at 6:41pm UTC
We've seen incidents of increased errors and latency in the Server API and Dashboard on us-east-1. We're currently investigating.
Affected services