Back to overview
Resolved

Increased Latency and Error Rates in US-East-1

Aug 24, 2026 at 2:40pm UTC
Affected services
Dashboard
Server API - Global (US)

Resolved
Aug 24, 2026 at 6:29pm UTC

The issue affecting service availability has been resolved. We deployed a fix and have confirmed normal performance across affected systems.

Updated
Aug 24, 2026 at 6:00pm UTC

A fix has been implemented and we are seeing normal behavior across affected systems. Our team is actively monitoring to confirm full stability before marking this incident as resolved.

Updated
Aug 24, 2026 at 5:39pm UTC

Applied a fix, beginning to see signs of recovery, team continuing to monitor error rates.

Updated
Aug 24, 2026 at 5:10pm UTC

We have identified the root cause of the increased latency and engineers are applying a fix now.

Updated
Aug 24, 2026 at 4:44pm UTC

Error and latency issues may also affect Dashboard users and we're updating our status to reflect.

Created
Aug 24, 2026 at 2:40pm UTC

Some customers may be experiencing increased latency and error rates in US-East-1. We're currently investigation the issue.